Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Re: Some VLANs don’t on some switches

Cisco Router, Firewall, VPN, SDM, ASA and Switch

Re: Some VLANs don’t on some switches

Postby blin » Wed Apr 18, 2012 4:32 pm

We have over 30 Cisco 3560 switches and over 10 VLANs on our network. In our example, all VLANs including VLAN 10 on switch IP 10.0.20.150 work fine and VLAN 10 on switch IP 10.0.20.24 doesn’t work (other VLAN 1 and 200 work). The below are both switches show vlan (both switches’ configuration can be found this link: viewto ... a55ac6f64d). On the switch 10.0.20.24, int g0/36 is configured for VLAN 10.
interface GigabitEthernet0/36
switchport access vlan 10
switchport mode access
flowcontrol receive desired
spanning-tree portfast
spanning-tree bpduguard enable
I can’t tell what causes the problem and how to fix it.
VLAN 10 on Switch 10.0.20 24 doesn’t work:
3560_6#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/1, Gi0/2, Gi0/3, Gi0/4
Gi0/5, Gi0/6, Gi0/7, Gi0/8
Gi0/9, Gi0/10, Gi0/11, Gi0/12
Gi0/13, Gi0/14, Gi0/15, Gi0/16
Gi0/17, Gi0/18, Gi0/19, Gi0/20
Gi0/21, Gi0/22, Gi0/23, Gi0/24
Gi0/25, Gi0/26, Gi0/27, Gi0/28
Gi0/29, Gi0/30, Gi0/31, Gi0/32
Gi0/33, Gi0/34, Gi0/36, Gi0/37
Gi0/38, Gi0/39, Gi0/40, Gi0/41
Gi0/42, Gi0/44, Gi0/45, Gi0/46
Gi0/47, Gi0/48, Gi0/51, Gi0/52
4 CAFE_PUPLIC_WIRELESS active
100 TEACHER active
200 STUDENT active Gi0/43
254 ICN_OUTSIDE active
255 Ccast_55.254 active
256 Ccast_56.94 active
300 PUBLIC active
400 VPNDMZ active
500 DMZ2 active

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
600 WIRELESSTRUNK active
700 WLC_TRUNK_NATIVE active
800 SAN active
900 VENDOR active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
100 enet 100100 1500 - - - - - 0 0
200 enet 100200 1500 - - - - - 0 0
254 enet 100254 1500 - - - - - 0 0
255 enet 100255 1500 - - - - - 0 0
256 enet 100256 1500 - - - - - 0 0
300 enet 100300 1500 - - - - - 0 0
400 enet 100400 1500 - - - - - 0 0
500 enet 100500 1500 - - - - - 0 0
600 enet 100600 1500 - - - - - 0 0
700 enet 100700 1500 - - - - - 0 0
800 enet 100800 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
900 enet 100900 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
------- -------- ----------------- ------------------------------------------
VLAN 10 on Switch 10.0.20 150 works
Switch#sh vlan
VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
1 default active Gi0/2, Gi0/3, Gi0/4, Gi0/5
Gi0/8, Gi0/9, Gi0/13, Gi0/23
Gi0/25, Gi0/26, Gi0/27, Gi0/28
4 CAFE_PUPLIC_WIRELESS active Gi0/1
10 VLAN0010 active Gi0/10, Gi0/22
20 HA-Cluster-LAN active
100 TEACHER active
200 STUDENT active Gi0/11, Gi0/12, Gi0/14, Gi0/15
Gi0/16, Gi0/17, Gi0/18, Gi0/19
Gi0/20
254 ICN_OUTSIDE active Gi0/6
255 Ccast_55.254 active
256 Ccast_56.94 active
300 PUBLIC active
400 VPNDMZ active
500 DMZ2 active
501 HYPER-V_HB active
502 HYPER-V_CSV active
503 HYPER-V_LM active
600 WIRELESSTRUNK active
700 WLC_TRUNK_NATIVE active

VLAN Name Status Ports
---- -------------------------------- --------- -------------------------------
800 SAN active Gi0/21
900 VENDOR active
1002 fddi-default act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default act/unsup
1005 trnet-default act/unsup

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
1 enet 100001 1500 - - - - - 0 0
4 enet 100004 1500 - - - - - 0 0
10 enet 100010 1500 - - - - - 0 0
20 enet 100020 1500 - - - - - 0 0
100 enet 100100 1500 - - - - - 0 0
200 enet 100200 1500 - - - - - 0 0
254 enet 100254 1500 - - - - - 0 0
255 enet 100255 1500 - - - - - 0 0
256 enet 100256 1500 - - - - - 0 0
300 enet 100300 1500 - - - - - 0 0
400 enet 100400 1500 - - - - - 0 0
500 enet 100500 1500 - - - - - 0 0
501 enet 100501 1500 - - - - - 0 0
502 enet 100502 1500 - - - - - 0 0
503 enet 100503 1500 - - - - - 0 0

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ----- ---------- ----- ------ ------ -------- ---- -------- ------ ------
600 enet 100600 1500 - - - - - 0 0
700 enet 100700 1500 - - - - - 0 0
800 enet 100800 1500 - - - - - 0 0
900 enet 100900 1500 - - - - - 0 0
1002 fddi 101002 1500 - - - - - 0 0
1003 tr 101003 1500 - - - - srb 0 0
1004 fdnet 101004 1500 - - - ieee - 0 0
1005 trnet 101005 1500 - - - ibm - 0 0
Remote SPAN VLANs
------------------------------------------------------------------------------
Primary Secondary Type Ports
How to Configure and Troubleshoot Cisco
http://www.howtocisco.com

Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com
blin
Site Admin
 
Posts: 3605
Joined: Wed Dec 31, 1969 7:00 pm
Location: Chicago, USA

Re: Some VLANs don’t on some switches

Postby blin » Wed Apr 18, 2012 7:48 pm

Switch 10.0.20.24 configuration:
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname 3560_6
no aaa new-model
ip subnet-zero
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree backbonefast
!
vlan internal allocation policy ascending
!
interface GigabitEthernet0/1
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/2
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/3
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/6
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/7
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/8
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/9
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/11
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/12
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/13
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/14
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/15
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/16
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/17
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/18
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/19
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/20
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/21
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/22
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/23
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/25
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/26
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/27
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/28
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/29
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/30
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/31
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/32
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/33
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/34
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/35
switchport trunk encapsulation dot1q
switchport mode trunk
flowcontrol receive desired
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/36
switchport access vlan 10
switchport mode access

flowcontrol receive desired
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/37
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/38
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/39
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/40
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/41
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/42
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/43
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/44
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/45
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/46
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/47
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/48
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/49
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/50
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/51
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/52
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface Vlan1
ip address 10.0.20.24 255.255.0.0
!
ip default-gateway 10.0.0.2
ip classless
ip http server
!
!
control-plane
!
!
line con 0
password
login
line vty 0 4
password
login
line vty 5 15
no login
!
!
end
How to Configure and Troubleshoot Cisco
http://www.howtocisco.com

Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com
blin
Site Admin
 
Posts: 3605
Joined: Wed Dec 31, 1969 7:00 pm
Location: Chicago, USA

Re: Some VLANs don’t on some switches

Postby blin » Wed Apr 18, 2012 7:48 pm

Switch 10.0.20.150 configuration
! Last configuration change at 12:09:15 CDT Tue Mar 27 2012 by blin
! NVRAM config last updated at 12:15:26 CDT Tue Mar 27 2012 by blin
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime
service password-encryption
service sequence-numbers
!
hostname Switch
!
no logging console guaranteed
no logging console
aaa new-model
aaa authentication login default local
aaa authentication login MYTAC group radius local
aaa authentication dot1x default group radius
aaa authorization exec MYTAC group radius if-authenticated
aaa authorization network default group radius
aaa accounting exec default start-stop group radius
!
aaa session-id common
clock timezone CST -6
clock summer-time CDT recurring
ip subnet-zero
!
!
!
!
dot1x system-auth-control
errdisable recovery cause psecure-violation
errdisable recovery interval 600
no file verify auto
spanning-tree mode pvst
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport access vlan 200
!
interface GigabitEthernet0/1
switchport access vlan 4
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 600
switchport mode trunk
spanning-tree portfast
!
interface GigabitEthernet0/3
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/5
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/6
description win2008
switchport access vlan 254
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/7
switchport trunk encapsulation dot1q
switchport trunk native vlan 600
switchport mode trunk
no mdix auto
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface GigabitEthernet0/8
!
interface GigabitEthernet0/9
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/10
description DMZ_ports
switchport access vlan 10
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/11
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/12
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/13
switchport trunk encapsulation dot1q
switchport trunk native vlan 600
switchport mode trunk
no mdix auto
spanning-tree portfast
spanning-tree bpdufilter enable
spanning-tree bpduguard enable
!
interface GigabitEthernet0/14
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/15
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/16
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/17
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/18
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/19
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/20
switchport access vlan 200
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/21
switchport access vlan 800
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/22
switchport access vlan 10
switchport mode access
spanning-tree portfast
spanning-tree bpduguard enable
!
interface GigabitEthernet0/23
switchport mode access
switchport port-security maximum 2
switchport port-security violation restrict
switchport port-security mac-address sticky
dot1x pae authenticator
dot1x port-control auto
spanning-tree portfast
!
interface GigabitEthernet0/24
switchport trunk encapsulation dot1q
switchport mode trunk
!
interface GigabitEthernet0/25
!
interface GigabitEthernet0/26
!
interface GigabitEthernet0/27
!
interface GigabitEthernet0/28
!
interface Vlan1
ip address 10.0.20.150 255.255.0.0
!
ip default-gateway 10.0.0.2
ip classless
ip http server
ip radius source-interface Vlan1
!
snmp-server community public RO
snmp-server community private RW
radius-server host 10.0.0.12 auth-port 1645 acct-port 1646 key
radius-server source-ports 1645-1646
!
control-plane
!
privilege exec level 2 show config
!
line con 0
line vty 0 4
authorization exec MYTAC
login authentication MYTAC
line vty 5 15
!
ntp clock-period 36028605
ntp server 128.105.39.11
end
How to Configure and Troubleshoot Cisco
http://www.howtocisco.com

Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com
blin
Site Admin
 
Posts: 3605
Joined: Wed Dec 31, 1969 7:00 pm
Location: Chicago, USA

Re: Some VLANs don’t on some switches

Postby blin » Wed Apr 18, 2012 7:53 pm

The problem is teh vlan 10 is not in the local database. To add it to the local database, please follow this post: How to add a VLAN to local database - viewtopic.php?f=5&t=15732
How to Configure and Troubleshoot Cisco
http://www.howtocisco.com

Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com
blin
Site Admin
 
Posts: 3605
Joined: Wed Dec 31, 1969 7:00 pm
Location: Chicago, USA


Return to Cisco

Your Ad Here

Who is online

Users browsing this forum: No registered users and 0 guests