Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

There has been an error creating the personal site

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

There has been an error creating the personal site

Postby guest » Wed Jul 08, 2009 10:54 am

Hi,

When creating a MySite users get this error message:

There has been an error creating the personal site. Contact your site administrator for more information.

Here is our setup:
o 1 web application for central administration
o 1 web application for ssp administration site
o 1 web application at port 80 (collaboration portal)
+ this web app uses (and requires) SSL
+ managed path: "mysite" (explicit inclusion)
+ managed path: "personal"(wildcard inclusion)
+ site collection based on the MySite Host on the "mysite" managed path
o SSP: personal site provider: https://[portalurl]:443/mysite/
o SSP: personal site location: "personal"

Initially we hosted the the MySites in a separate web application, but we migrated them to this new setup. The users who had a mysite before the migration have no issue, they can get to their mysite just fine.

If I look in the SharePoint logs I find this error message: "Value does not fall within the expected range"

Any ideas what we are doing wrong?

Here's an extract of the logfile:

CreatePersonalSite: Testing for personal site at: https://[portalurl]/personal/demo. e3066f3f-0715-472d-b67e-e59fee093a90
Attempting to create personal site at 'https://[portalurl]/personal/demo'. e3066f3f-0715-472d-b67e-e59fee093a90
Creating site https://[portalurl]/personal/demo in content database [contentdatabasename]
Creating top level site at https://[portalurl]/personal/demo
Unknown SPRequest error occurred. More information: 0x80070057
The site /personal/demo could not be created. The following exception occured: Value does not fall within the expected range..
Failed to create personal site ([domain]\demo, https://[portalurl]/personal/demo): System.ArgumentException: Value does not fall within the expected range. at Microsoft.SharePoint.Library.SPRequestInternalClass.SscCreateSite(Guid gApplicationId, String bstrUrl, String bstrServerRelativeUrl, Int32 lZone, Guid gSiteId, Guid gDatabaseId, String bstrDatabaseServer, String bstrDatabaseName, String bstrDatabaseUsername, String bstrDatabasePassword, String bstrTitle, String bstrDescription, UInt32 nLCID, String bstrWebTemplate, String bstrOwnerLogin, String bstrOwnerName, String bstrOwnerEmail, String bstrSecondaryContactLogin, String bstrSecondaryContactName, String bstrSecondaryContactEmail, Boolean bADAccountMode) at Microsoft.SharePoint.Library.SPRequest.SscCreateSite(Guid gApplicat... e3066f3f-0715-472d-b67e-e59fee093a90
...ionId, String bstrUrl, String bstrServerRelativeUrl, Int32 lZone, Guid gSiteId, Guid gDatabaseId, String bstrDatabaseServer, String bstrDatabaseName, String bstrDatabaseUsername, String bstrDatabasePassword, String bstrTitle, String bstrDescription, UInt32 nLCID, String bstrWebTemplate, String bstrOwnerLogin, String bstrOwnerName, String bstrOwnerEmail, String bstrSecondaryContactLogin, String bstrSecondaryContactName, String bstrSecondaryContactEmail, Boolean bADAccountMode) at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail... e3066f3f-0715-472d-b67e-e59fee093a90
..., String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName) at Microsoft.SharePoint.SPSite.SelfServiceCreateSite(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String contactLogin, String contactName, String contactEmail, String quotaTemplate) at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0(). e3066f3f-0715-472d-b67e-e59fee093a90
My Site creation failure for user '[domain]\demo' for site url 'https://[portalurl]/personal/demo'. The exception was: Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> System.ArgumentException: Value does not fall within the expected range. at Microsoft.SharePoint.Library.SPRequestInternalClass.SscCreateSite(Guid gApplicationId, String bstrUrl, String bstrServerRelativeUrl, Int32 lZone, Guid gSiteId, Guid gDatabaseId, String bstrDatabaseServer, String bstrDatabaseName, String bstrDatabaseUsername, String bstrDatabasePassword, String bstrTitle, String bstrDescription, UInt32 nLCID, String bstrWebTemplate, String bstrOwnerLogin, String bstrOwnerName, String bstrOwnerEmail, String bstrSecondaryContactLo... e3066f3f-0715-472d-b67e-e59fee093a90
...gin, String bstrSecondaryContactName, String bstrSecondaryContactEmail, Boolean bADAccountMode) at Microsoft.SharePoint.Library.SPRequest.SscCreateSite(Guid gApplicationId, String bstrUrl, String bstrServerRelativeUrl, e3066f3f-0715-472d-b67e-e59fee093a90
Exception while creating personal site for '[domain]\demo': Microsoft.Office.Server.UserProfiles.PersonalSiteCreateException: A failure was encountered while attempting to create the site. ---> System.ArgumentException: Value does not fall within the expected range. at Microsoft.SharePoint.Library.SPRequestInternalClass.SscCreateSite(Guid gApplicationId, String bstrUrl, String bstrServerRelativeUrl, Int32 lZone, Guid gSiteId, Guid gDatabaseId, String bstrDatabaseServer, String bstrDatabaseName, String bstrDatabaseUsername, String bstrDatabasePassword, String bstrTitle, String bstrDescription, UInt32 nLCID, String bstrWebTemplate, String bstrOwnerLogin, String bstrOwnerName, String bstrOwnerEmail, String bstrSecondaryContactLogin, String bstrSecondaryContactName, String bstrSecondaryContac... e3066f3f-0715-472d-b67e-e59fee093a90
...tEmail, Boolean bADAccountMode) at Microsoft.SharePoint.Library.SPRequest.SscCreateSite(Guid gApplicationId, String bstrUrl, String bstrServerRelativeUrl, Int32 lZone, Guid gSiteId, Guid gDatabaseId, String bstrDatabaseServer, String bstrDatabaseName, String bstrDatabaseUsername, String bstrDatabasePassword, String bstrTitle, String bstrDescription, UInt32 nLCID, String bstrWebTemplate, String bstrOwnerLogin, String bstrOwnerName, String bstrOwnerEmail, String bstrSecondaryContactLogin, String bstrSecondaryContactName, String bstrSecondaryContactEmail, Boolean bADAccountMode) at Microsoft.SharePoint.Administration.SPSiteCollection.Add(SPContentDatabase database, String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, ... e3066f3f-0715-472d-b67e-e59fee093a90
...String ownerEmail, String secondaryContactLogin, String secondaryContactName, String secondaryContactEmail, String quotaTemplate, String sscRootWebUrl, Boolean useHostHeaderAsSiteName) at Microsoft.SharePoint.SPSite.SelfServiceCreateSite(String siteUrl, String title, String description, UInt32 nLCID, String webTemplate, String ownerLogin, String ownerName, String ownerEmail, String contactLogin, String contactName, String contactEmail, String quotaTemplate) at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0() --- End of inner exception stack trace --- at Microsoft.Office.Server.UserProfiles.UserProfile.<>c__DisplayClass2.<CreateSite>b__0() at Microsoft.SharePoint.SPSecurity.CodeToRunElevatedWrapper(Object state) at Microsoft.Shar... e3066f3f-0715-472d-b67e-e59fee093a90
...ePoint.SPSecurity.<>c__DisplayClass4.<RunWithElevatedPrivileges>b__2() at Microsoft.SharePoint.Utilities.SecurityContext.RunAsProcess(CodeToRunElevated secureCode) at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(WaitCallback secureCode, Object param) at Microsoft.SharePoint.SPSecurity.RunWithElevatedPrivileges(CodeToRunElevated secureCode) at Microsoft.Office.Server.UserProfiles.UserProfile.CreateSite(String strRequestUrl, Boolean bCollision, Int32 lcid) at Microsoft.Office.Server.UserProfiles.UserProfile.CreatePersonalSite(Int32 lcid). e3066f3f-0715-472d-b67e-e59fee093a90
An SPRequest object was not disposed before the end of this thread. To avoid wasting system resources, dispose of this object or its parent (such as an SPSite or SPWeb) as soon as you are done using it. This object will now be disposed. Allocation Id: {0A19DC65-7DF4-462B-9C4B-955C92521D53} To determine where this object was allocated, create a registry key at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\HeapSettings. Then create a new DWORD named SPRequestStackTrace with the value 1 under this key.
BackgroundTaskManager.ExecuteBackgroundTasks: Starting task SessionManager.PerformSessionTimeouts

Answers

Hi Ton,



In the setup you supplied add the account configured as the Applicaiton Pool Identity for the web site at port 80 (collaboration portal) to the "Farm Administrators" group through the Central Administration pages.

After that perform an IISReset.

This should fix the problem.

I am still performing some research on this matter to determine the impact of adding the AppPool identity to your Farm Administrators group.





During my research so far I also found another solution below:

Another way to get arround this issue is to add the AppPool identity to the "Local Administrators" group on every web front-end server hosting the web site under which the My Sites are created but this has impact on the machine security.

While making a My Site some process in the back needs certain local permissions on the web front-end machines which are provided either by adding the AppPool identity to the "Local Administrators" group or by adding it to the "Farm Administrators" group through Central Administration pages.


o ReplyReply
o QuoteQuote


All Replies

*
Friday, February 09, 2007 12:30 PMkiral Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0

My guess is that your managed paths configuration is invalid. What you should do is delete the personal path altogether (since you create sites under mysite). And change the inclusion type for mysite to wildcard. In the current setup, requests to mysite/personal are ignored by SharePoint because explicit inclusion only means this exact path is taken over by SharePoint, not its descendants.

Hope this helps,
o ReplyReply
o QuoteQuote

*
Friday, February 09, 2007 4:17 PMTon Stegeman [MVP]MVPUsers MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
yes! that did the trick. thanks
o ReplyReply
o QuoteQuote

*
Friday, February 09, 2007 4:18 PMTon Stegeman [MVP]MVPUsers MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
thanks for the help kiral, but the managed paths actually are correct. It now works thanks to Vincent's reply.
o ReplyReply
o QuoteQuote

*
Wednesday, August 22, 2007 8:57 PMErik Bo Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0



Thanks - this made my day!

There should be a hot fix on its way from MS though?


o ReplyReply
o QuoteQuote

*
Wednesday, October 03, 2007 6:10 AMDelnari Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0

Just so I'm on the same page as everyone else. The fix was to use the AppPool Indentity in the "Administrators" group on the local front-end server? My current setup is a stand-alone portal server and the AppPool Indentity being used is the network service account IWAM_server-name. Can I use this account or should I change to another admin account in the AppPool Identity? Thanks for lack of understanding...



Tom


o ReplyReply
o QuoteQuote

*
Thursday, November 22, 2007 3:53 PMjmmmmm Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0



Adding the users to the farm admin worked like a champ!



Thanks!
o ReplyReply
o QuoteQuote

*
Friday, August 01, 2008 2:30 AMBen K_ Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
This worked for me, too. You're a champ!
o ReplyReply
o QuoteQuote

*
Tuesday, October 14, 2008 2:04 PMShamanovsky Victor Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
Try doing IISRESET before doing anything else.
o ReplyReply
o QuoteQuote

*
Friday, November 07, 2008 3:13 PMNiketu Bhatt Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals
Proposed Answer
Vote As Helpful
0
Vincent's fix works really good. The other solution I found to this was to enable ASP .Net impersonation in IIS (IIS 7). This will allow the worker process to impersonate the logged in administrator account and should work flawlessly....I believe this solution would be also more secured.
o Proposed As Answer byNiketu Bhatt Friday, November 07, 2008 3:14 PM
o Edited byNiketu Bhatt Friday, November 07, 2008 3:15 PM
o
o ReplyReply
o QuoteQuote

*
Friday, April 17, 2009 3:20 PMBhuttan Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
How to set the Application pool identity to Farm administrators. I am goin to IIS manager and right click application pool ->properties->identity tab but there is no option of setting it to farm administrators.The option that I am getting is Network Service,Local Service and Local System but no option of Farm administrators.Can anyone help me in this.Regards, Bhuttan
o ReplyReply
o QuoteQuote

*
Wednesday, April 29, 2009 6:07 AMXiaofeng WangMVPUsers MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals
Proposed Answer
Vote As Helpful
0
Hello,

The same error happened to me. It indeed results from the account servicing for the Applicaton Pool of MySite.

But it fails againt even I add the account to the 'Farm Administrators' group or the local 'Administrators' group of the Web Server.

At last it works when I take the MOSS config account for the Application Pool.

In my case, I put the SSP and MySite in the same IIS site. I think that the SSP requires much more permissions.

It's a big challenge for us to do the troubleshooting. Hope that the SharePoint team gives more senseful messages about this kind of error in future version.

My original post: http://social.technet.microsoft.com/For ... 38a501533f

Hope helpful.
Xiaofeng Wang | MVP(ASP/ASP.NET) | Beijing P.R.C
o Proposed As Answer byXiaofeng WangMVPWednesday, April 29, 2009 6:07 AM
o
o ReplyReply
o QuoteQuote

*
Wednesday, July 01, 2009 6:45 AMMuhammedh Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
A twist to the above given solution:

I added the AppPool user as the Farm administrator and clicked on the mysite link. The profile got created. SUCESS!!

Then, i removed the AppPool user from the Farm admin group, and clicked my site link as a different user (this user does not have a profile created yet) and the profile got created. SUCCESS!!


o ReplyReply
o QuoteQuote

*
Wednesday, July 01, 2009 1:05 PMPants79 Users MedalsUsers MedalsUsers MedalsUsers MedalsUsers Medals

Vote As Helpful
0
This has also fixed it for me.

To the above poster: Did you also do an IISRESET in between the tests?

Thanks.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Return to Networking

Your Ad Here

Who is online

Users browsing this forum: Google Adsense [Bot] and 6 guests