Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

Can't see public folder after changing permissions

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

Can't see public folder after changing permissions

Postby chicagotech » Sat Oct 25, 2008 3:02 pm

Q: One of our users tried to reset permission on one of public folders. She might reset all user permissions including herself to none. Now, no one can see the folder any more. I can see the folder from exchange system manager and re-assign permissions, but still can't see the folder from the Outlook. How do you fix it?

A: According to my experience, this issue could occur if the Default and
Anonymous accounts are not configured correct permissions.

To fix this issue, we can use the following method:

=============

1. Start the Exchange System Manager (ESM), navigate to the problematic
public folder

2. Right click the folder and choose Properties.

3. Switch to Permissions tab and click Client Permissions tab. Then grant
the permission as the following:

Default: Author
Anonymous: Contributor

This is the default configuration for the Default and Anonymous accounts

Then add other users you want to grant permissions to.

4. Click OK.

Wait for some time until replication completes.

Test if the public folder are available now.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 7066
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Sat Oct 25, 2008 3:03 pm

I followed your instruction to grant Default: Author and Anonymous:
Contributor, but the folder doesn't show up. It is over 5 hours. The OWA
doesn't show it.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 7066
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Sat Oct 25, 2008 3:03 pm

I understand the issue persists after granting permissions to the Default
and Anonymous accounts.

Based on further research, I'd like to suggest trying the following steps

==============

1. In Exchange System Manager (ESM), under the Public Folders tree, create
a new top-level folder.

2. Move the affected folder and subfolders into this new created top-level
folder (you can direct drag the affected folder in ESM).

3. Set the permissions on the new top-level folder so that an account with
administrator permissions in Active Directory is the owner.

4. Right-click the new top-level folder, point to All Tasks, click
Propagate Settings, and then select the Administrative Rights and Folder
Rights check boxes.

5. After you click OK, the changes to the permissions are applied to all
subfolders of the new top-level folder.

6. Move the affected folder and subfolders back to their original locations
in the Public Folders tree.

7. Verify if that public folder is available to users now
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 7066
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA

Postby chicagotech » Sat Oct 25, 2008 3:03 pm

Thank you. That works.
Networking, Internet, Routing, VPN Troubleshooting on http://www.ChicagoTech.net
How to Setup Windows, Network, VPN & Remote Access on http://www.HowToNetworking.com
chicagotech
Site Admin
 
Posts: 7066
Joined: Mon Nov 27, 2006 1:24 pm
Location: Chicago USA


Return to Networking

Your Ad Here

Who is online

Users browsing this forum: No registered users and 6 guests