Home | Site Map | Cisco How ToNet How To | Wireless |Search | Forums | Services | Donations | Careers | About Us | Contact Us|

can't delete public folders after migrating to exchange 2007

Network Sharing , TCP/IP, Internet, Wireless, Exchange, IIS, ISA and Print

can't delete public folders after migrating to exchange 2007

Postby guest » Sun Oct 19, 2008 9:17 pm

you have migrated from an Exchange 2003 server to an
Exchange 2007 server. You want to delete all the public folders because
public folders in Exchange Server 2007 are no longer necessary if all
client computers in your organization are running Microsoft Office Outlook
2007. However, you received an error when you try to delete them.

The error indicates that required you might not have the proper permission
to delete Public Folders.

To troubleshoot the issue, I suggest you to perform the following steps:

1. Type ADSIEDIT.msc in run.
2. Expand to CN=Public Folders,CN=Folder Hierarchies,CN=Exchange
Administrative Group (FYDIBOHF23SPDLT),CN=Administrative
Groups,CN=<Orgname>,CN=Microsoft
Exchange,CN=Services,CN=Configuration,DC=<domainname>,DC=com.
3. Right click on Public Folders and select Properties.
4. Under Security tab, make sure you allow full control for Everyone group.

Please make a test after that.

If the issue persists, I suggest you to delete the public folder database
directly. To do this, please perform the following steps:

1. Open EMC.
2. In the console tree, expand Server Configuration, and then click Mailbox.
3. In the result pane, click the server from which you want to remove the
public folder database.
4. In the work pane, expand the storage group from which you want to remove
the public folder database, and then click the public folder database that
you want to remove.
5. In the action pane, click Remove. A message appears asking if you are
sure that you want to remove the database. Click Yes.

I did both options:

1) ADSIEDIT, No "Folder Hierarchies\Public Folders" under the "Exchange
Administrative Group (FYDIBOHF23SPDLT).

I have two CNs under CN=Administrative Groups, 1) CN=Exchange Administrative
Group (FYDIBOHF23SPDLT) and 2) CN=Orgname (This is the one from my 2003
exchange environement). Under CN=Orgname, I have a CN=Folder
Hierarchies\CN=Public Folders, and I set the "Everyone Group" to full
control.

Then tried from PF Folder mangage under toolbox, stil receive the errors
previously mention, went to step two.


2) EMC - Manually delete PF Database, received following error.

--------------------------------------------------------
Microsoft Exchange Error
--------------------------------------------------------
The public folder database 'Public Folder Database' cannot be deleted.

Public Folder Database
Failed
Error:
The public folder database "TQEXCH2\Second Storage Group\Public Folder
Database" contains the following offline address book(s):
\Default Offline Address List
. Before deleting the public folder database, move the offline address
book(s) to a web-based distribution point.


Based on the error message that you received when deleting the public
folder database, I suggest you to perform the following steps to further
troubleshoot the issue:

1. Open EMC.

2. Create a new OAB that was configured to only use Web Distribution
=======
a. In the console tree, expand Organization Configuration, and then click
Mailbox.
b. In the action pane, click New Offline Address Book. The New Offline
Address Book wizard appears.
c. On the Introduction page, complete the following fields:
- Name: Use this box to provide a name for the OAB.
- Offline Address Book Generation Server: Click Browse to specify the
location where the OAB generation server will be located. The OAB
generation server is the Mailbox server on which the OABs are generated.
- Include the Default Global Address List: Select this check box to include
the default GAL in the OAB.
d. Click Next.
e. Select Enable Web-based distribution and then click Add to add virtual
directories from which to distribute the OAB.
f. Click Next.
g. On the New Offline Address Book page, review your configuration
settings. Click New to create the offline address book.

3. Set it as default OAB.
=======
Right click on the new OAB and select "Set as Default".

4. Delete the Default OAB.
=======
Right click on the "Default offline address book" and select remove.

After that, please try to delete the public folder database again.

If the error persists, please perform the following to delete the public
folder database:

1. Type ADSIEDIT.msc in run.
2. Expand to CN=Public Folder Database,CN=Second Storage
Group,CN=Information Store,CN=Server_Name,CN=Servers,CN=Exchange
Administrative Group (FYDIBOHF23SPDLT),CN=Administrative
Groups,CN=<Orgname>,CN=Microsoft
Exchange,CN=Services,CN=Configuration,DC=<domainname>,DC=com.
3. Right click on Public Folder Database and select Delete.

Thanks! Creating the temporary OAB as a default fixed my issue, here were my
steps.

1) TempOAB, set as default
2) Remove Public Folder Database from EMC\ServerConfiguration\Mailbox
3) Remove the .edb
4) Remove my storage group containting the PF database
5) Remove my storage group path log files
6) Remove the TempOAB

Thanks for the help, I am now completely Exchagne 2007 native.
Tablet and Smartphone Setup Guide
http://www.quicksetupguide.com

Troubleshooting Vista Wireless
http://chicagotech.net/
guest
 
Posts: 10191
Joined: Mon Nov 27, 2006 1:10 pm

Return to Networking

Your Ad Here

Who is online

Users browsing this forum: Google Adsense [Bot] and 9 guests